PDA

View Full Version : I need a help about SG3525



dinithm
02-11-2014, 04:52 AM
I made SMPS for a car amplifier,
but there is un expectable spike on it

this is the waveform at IDLE
4500
1A load
4501
heavy loads (<3A output)
4502
this is data of my transformer
4503

45044505

can u pleas tell me ,what is the reason of that matter.and what do I do to resettle this ,
thank you.

ultra
02-13-2014, 08:04 PM
why do you use R1 (10R) to ground your secondary output to gnd?

dinithm
02-14-2014, 04:45 PM
R1 10ohms- its LOAD resistance for testing

dondivert
02-14-2014, 05:52 PM
please send the download link to troubleshooting and repairing switch mode power supply by Jestine Yong am new in the site Thanks in advance. my email is gentledivert@yahoo.com

dondivert
02-14-2014, 06:01 PM
please i need the book troubleshooting and repairing switch mode power supply by Jestine Yong thanks in advance my email is gentledivert@yahoo.com

ultra
02-14-2014, 06:04 PM
Can you post a photo of the gate pad of the fets in primary?

dinithm
02-15-2014, 05:17 AM
Can you post a photo of the gate pad of the fets in primary?

451045114512

dinithm
02-15-2014, 05:20 AM
the transformer that I pick from another car amplifier working perfectly instead of my transformer
45134514

so what can I do for my transformer,

thank you

ultra
02-15-2014, 05:43 AM
Since you are using a transformer from another amp, lower the Fosc to around 50KHz and see what happens.

dinithm
02-15-2014, 09:26 AM
Since you are using a transformer from another amp, lower the Fosc to around 50KHz and see what happens.
nothing happen

35khz to 150khz
it s spike level is different but not good

angellina
05-16-2016, 11:01 PM
I made SMPS for a car amplifier,
but there is un expectable spike on it

this is the waveform at IDLE
4500
1A load
4501
heavy loads (<3A output)
4502
this is data of my transformer
4503

45044505

can u pleas tell me ,what is the reason of that matter.and what do I do to resettle this ,
thank you.

Is it working swiftly now....... (http://www.caraudiogiants.com/shop-by-category/amplifiers/soundstream-p4-800.html)!

dinithm
05-18-2016, 09:14 AM
no its not working

Voitano
05-18-2016, 05:27 PM
Try to eliminate gap in the transformer core as much as you can.

Redwire
05-20-2016, 04:14 AM
Can you post your actual schematic?

I am seeing the MOSFET take a very long time to switch, about 1.5 usec
I would guess problems with the driver, looks like turn ON time is too slow, or way too much deadtime.

Your transformer calc. tool shows 2usec deadtime on 70kHz PWM which I think is too much.
Why 21AWG secondary winding for 4A? Seems a bit thin.

SG3525 can have troubles driving big mosfets, especially if you have no filter between Vc and V.

dinithm
05-20-2016, 04:22 AM
I bought (T45-26-15 PC40) from aliexpress

but I didnt compliet the circuit yet


http://www.aliexpress.com/item/fast-shipping-ring-Toroidal-transformer-ferrite-core-MnZn-PC40-material-T45-26-15-5pcs-lot/32366482814.html?spm=2114.01010208.3.319.WlAwAX&ws_ab_test=searchweb201556_0,searchweb201602_3_100 17_10021_507_10022_10020_10009_10008_10018_10019_1 01,searchweb201603_9&btsid=2c21f48b-22c6-4aac-8c87-8d4356ee39aa